Bolt action Saiga...

Discussion in 'Rifles' started by hoytinak, Nov 29, 2008.

  1. hoytinak

    hoytinak Active Member

    668
    0
    36
    Mar 5, 2008
    Texas of course
    I finally got the Saiga out today for the first time after putting the Ultimak and red dot on it. Well, it's chambering the rounds fine but the bolt's not resetting the trigger. I was having to charge it by hand, ejecting the chambered round so it'd reset the trigger (works has it should by hand but not firing). I thought that since this was the first time out with the Ultimak on it that might be it but I replaced the Ultimak with the original gas tube and it's still doing it. Any suggestions?
     


  2. snscott

    snscott New Member

    8
    0
    1
    Apr 5, 2008
    Great Republic Of Texas
    So the empty is not ejecting, but you can eject it and chamber the next round by hand? I assume that means that the bolt is not moving when you fire?
     
  3. hoytinak

    hoytinak Active Member

    668
    0
    36
    Mar 5, 2008
    Texas of course
    It's ejecting the empty and rechambering a new round, just not resetting the trigger.
     
  4. mac79912

    mac79912 Well-Known

    1,666
    0
    36
    Mar 4, 2008
    Mine ended up being a sear problem.I ended up changing out the sear and put in a Tapco g2 trigger.
     
  5. O.S.O.K.

    O.S.O.K. Member

    Do a pistol grip conversion. Its easy and doesn't cost much either.

    Check this: Saiga Conversion

    Will look like this when you're done:

    [​IMG]

    I didn't have the fire control group when I took the pic - used a Tapco G-2 fcg and its great.

    Besides the "correct" configuration, you also get a much better trigger.
     

Share This Page