DPMS Sportical Bolt Catch Not Working

Discussion in 'Video How-To's and Tutorials' started by SeismicTrash, Jan 22, 2014.

  1. SeismicTrash

    SeismicTrash New Member

    5
    0
    1
    Jan 21, 2014
    I purchased this .308 Sportical in November brand new. Since, I have ran less than 100 rounds through it due to a different issue. Now the bolt catch won't hold the action open unless I hold the button down. If I let off and barely look at the gun, it slams shut. Can't find anything on this petty issue. Thinking I bought a dud... Any help is greatly appreciated. Thanks
     


  2. Dawico

    Dawico TGT Addict

    27,004
    508
    113
    Oct 15, 2009
    Lampasas, Texas
    We recently had a thread on this but anyways, my DPMS AR 10 does the same thing. I got it used and it never worked. I haven't tinkered with it yet.
     
  3. 556.45.12

    556.45.12 Active Member

    485
    0
    16
    Mar 8, 2013
    Houston, TX
    Sounds like a worn/broken bolt catch - just drive out that roll pin and put a new one in - should fix your problem.
     
  4. cbigclarke

    cbigclarke TGT Addict

    20,363
    14
    38
    Feb 24, 2009
    cypress
    Make them fix it. Its still under warranty

    Sent from my DROID RAZR using Tapatalk
     
  5. Vaquero

    Vaquero Pre-ban Staff Member Admin

    26,669
    337
    83
    Apr 4, 2011
    Out West
    Yep.
     
  6. SeismicTrash

    SeismicTrash New Member

    5
    0
    1
    Jan 21, 2014
    I just found this website / joined last night and 4 replies within 24 hours. I appreciate your advice guys. Let me know if you need assistance on fixing a Red Rider BB gun...
     
  7. A.Texas.Yankee

    A.Texas.Yankee TGT Addict

    3,553
    2
    38
    Mar 21, 2012
    NTX
    It's a pretty simple issue to diagnose. Does the bolt lock back easily with an empty magazine in it? Being only from November I would send it to them to do with if you aren't too comfortable doing anything on your own.

    Sent from my EVO 4G LTE using Tapatalk
     
  8. mitchntx

    mitchntx Sarcasm Sensei TGT Supporter

    3,792
    13
    38
    Jan 15, 2012
    SW of FW
    Have you replaced the stock?

    My issue was the replacement stock had a cheek piece that ever so slightly interfered with getting a full stoke on the bolt with the charging handle.
     
  9. KiloKilo

    KiloKilo Active Member

    368
    0
    16
    Aug 30, 2013
    Hhhmmm.....I've had this same problem develop just a few days ago. But I have installed the Phase 5 (B.A.D. lever). I am going to reinstall the factory catch and see if that fixes the problem. A close visual inspection of the Phase 5 does not show any wear.....I have only fired about 200 rounds total thru this rifle, of which, 90 rounds with Phase 5. We'll see...............
     
  10. KiloKilo

    KiloKilo Active Member

    368
    0
    16
    Aug 30, 2013
    Thanks mitchtx......I just read your post and it "clicked" .......I had just added the Magpul 1/4" cheek riser on my CTR stock. They note there could be interference with the charging handle. By golly, that's what my problem was. I pulled off the riser and wham.....works like a charm. Looks like I'll be getting out the Dremel tool tomorrow.

    Many Thanks.....GREAT FORUM !!!

    KK
    '
     

Share This Page